Opened 5 years ago

Closed 5 years ago

#424 closed defect (fixed)

'buffer' test crashes in Py3.1.1

Reported by: scoder Owned by: dagss
Priority: minor Milestone: 0.12
Component: Code Generation Keywords:
Cc:

Description

compiling (c) and running buffer ... Doctest: buffer ... python3.1: Objects/memoryobject.c:467: memory_dealloc: Assertion `g->gc.gc_refs != (-2)' failed.
Aborted

Change History (6)

comment:1 Changed 5 years ago by dagss

I can't reproduce this. However I had to to a change to make the testcase run -- the underlying buffer acquired for the test was now unicode. Do you think this was related to the unicode object?

http://hg.cython.org/cython-devel/rev/efc9b37cd3cd

comment:2 Changed 5 years ago by dagss

I meant, the crash. What happened for me was basically that the buffer could not be acquired because an exception was raised when assigning the unicode to char*. However there was no crashes for me ever.

comment:3 Changed 5 years ago by dagss

  • Owner changed from dagss to sbehnel

comment:4 Changed 5 years ago by dagss

  • Owner changed from sbehnel to scoder

comment:5 Changed 5 years ago by scoder

  • Owner changed from scoder to dagss
  • Priority changed from blocker to minor

Works for me now. Would be good to disallow <char*>some_str_object, though.

comment:6 Changed 5 years ago by scoder

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.