Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#421 closed defect (fixed)

docstrings on "__nonzero__()" method break module-init code in Py3.1

Reported by: scoder Owned by: dagss
Priority: minor Milestone: 0.12
Component: Code Generation Keywords:
Cc:

Description

__nonzero__ is renamed to __bool__ in Py3.1. However, the code that Cython generates to set the docstring tries to access the method through the type dict where it cannot be found in Py3.1 due to the renaming. This leads to an AttributeError on module import.

Change History (5)

comment:1 Changed 5 years ago by dagss

  • Resolution set to fixed
  • Status changed from new to closed

The problem is with the autotestdict code (and the docstring is actually fetched). A better approach is needed in general, so for 0.12 we're blacklisting slots that cause problems.

http://hg.cython.org/cython-devel/rev/7289c41ad3c3

comment:2 Changed 5 years ago by robertwb

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:3 Changed 5 years ago by robertwb

  • Owner changed from somebody to dagss
  • Status changed from reopened to new

comment:4 Changed 5 years ago by robertwb

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 5 years ago by robertwb

  • Milestone changed from wishlist to 0.12
Note: See TracTickets for help on using tickets.