Opened 6 years ago

Closed 6 years ago

#278 closed defect (fixed)

Sage segfaults

Reported by: robertwb Owned by: robertwb
Priority: blocker Milestone: 0.11.1
Component: Code Generation Keywords:
Cc:

Description

        ./sage -t  devel/sage/sage/rings/bernmm.pyx # Segfault
        ./sage -t  devel/sage/doc/en/bordeaux_2008/birds_other.rst # Segfault

Change History (6)

comment:1 Changed 6 years ago by robertwb

  • Owner changed from somebody to robertwb

The good news is that Sage compiles without modification. Of note

        ./sage -t  devel/sage/sage/libs/ntl/ntl_ZZ_pX.pyx # 1 doctests failed
        ./sage -t  devel/sage/sage/rings/integer.pyx # 1 doctests failed

are bugs in Sage (passing -1 to something expecting an unsigned integer now always raises an error)

comment:2 Changed 6 years ago by robertwb

The following also all time out

        ./sage -t  devel/sage/sage/combinat/root_system/weyl_characters.py # 0 doctests failed
        ./sage -t  devel/sage/sage/modular/abvar/homspace.py # 0 doctests failed
        ./sage -t  devel/sage/sage/modular/abvar/abvar.py # 0 doctests failed
        ./sage -t  devel/sage/sage/quadratic_forms/quadratic_form__local_representation_conditions.py # 0 doctests failed
        ./sage -t  devel/sage/sage/coding/decoder.py # 0 doctests failed

comment:3 Changed 6 years ago by robertwb

All tests eventually pass on modular/abvar/homspace.py, seems to be a serious speed regression.

comment:4 Changed 6 years ago by robertwb

Hmm... apparently this isn't new.

Cython 0.10.x

sage: time J0(123).decomposition()
CPU times: user 0.55 s, sys: 0.03 s, total: 0.58 s
Wall time: 0.96 s

Cython 0.11

sage: sage: sage: time J0(123).decomposition()
CPU times: user 14.63 s, sys: 0.01 s, total: 14.64 s
Wall time: 14.73 s

Cython 0.11.1

sage: time J0(123).decomposition()
CPU times: user 13.44 s, sys: 0.03 s, total: 13.47 s
Wall time: 13.48 s

comment:5 Changed 6 years ago by robertwb

Re the timings, I was testing with the refnanny enabled.

comment:6 Changed 6 years ago by robertwb

  • Resolution set to fixed
  • Status changed from new to closed

OK, it looks like all is well now.

Note: See TracTickets for help on using tickets.