Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#160 closed enhancement (duplicate)

support for subinterpreters and module cleanup in Py3

Reported by: scoder Owned by: somebody
Priority: major Milestone: Dupe/Invalid
Component: Code Generation Keywords:
Cc:

Description

Py3 implements PEP 3121 that changes the way modules can handle global state. This will allow independent sub-interpreters in he future.

http://www.python.org/dev/peps/pep-3121/

Cython modules should support this out of the box.

Change History (2)

comment:1 Changed 6 years ago by scoder

  • Resolution set to duplicate
  • Status changed from new to closed

This is now a duplicate of the more complete #173.

comment:2 Changed 6 years ago by robertwb

  • Milestone changed from wishlist to Dupe/Invalid
Note: See TracTickets for help on using tickets.