Ticket #421 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

docstrings on "__nonzero__()" method break module-init code in Py3.1

Reported by: scoder Owned by: dagss
Priority: minor Milestone: 0.12
Component: Code Generation Keywords:
Cc:

Description

__nonzero__ is renamed to __bool__ in Py3.1. However, the code that Cython generates to set the docstring tries to access the method through the type dict where it cannot be found in Py3.1 due to the renaming. This leads to an AttributeError on module import.

Change History

Changed 5 years ago by dagss

  • status changed from new to closed
  • resolution set to fixed

The problem is with the autotestdict code (and the docstring is actually fetched). A better approach is needed in general, so for 0.12 we're blacklisting slots that cause problems.

 http://hg.cython.org/cython-devel/rev/7289c41ad3c3

Changed 4 years ago by robertwb

  • status changed from closed to reopened
  • resolution fixed deleted

Changed 4 years ago by robertwb

  • owner changed from somebody to dagss
  • status changed from reopened to new

Changed 4 years ago by robertwb

  • status changed from new to closed
  • resolution set to fixed

Changed 4 years ago by robertwb

  • milestone changed from wishlist to 0.12
Note: See TracTickets for help on using tickets.