Ticket #160 (closed enhancement: duplicate)

Opened 5 years ago

Last modified 5 years ago

support for subinterpreters and module cleanup in Py3

Reported by: scoder Owned by: somebody
Priority: major Milestone: Dupe/Invalid
Component: Code Generation Keywords:
Cc:

Description

Py3 implements PEP 3121 that changes the way modules can handle global state. This will allow independent sub-interpreters in he future.

 http://www.python.org/dev/peps/pep-3121/

Cython modules should support this out of the box.

Change History

Changed 5 years ago by scoder

  • status changed from new to closed
  • resolution set to duplicate

This is now a duplicate of the more complete #173.

Changed 5 years ago by robertwb

  • milestone changed from wishlist to Dupe/Invalid
Note: See TracTickets for help on using tickets.